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Brain Explorer® 3-D Viewer is an application for viewing brain anatomy, gene expression and fluorescence projection data in three dimensions in
the framework of the Allen Reference Atlas.
Using Brain Explorer, you can:
• View a fully interactive version of the Allen Reference Atlas in 3-D.
• View gene expression data in 3-D at 200 µm3 resolution.
• View projection data in 3-D at 100 µm3 resolution.
• View expression data and projection data from multiple experiments superimposed on each other in 3-D.
• Navigate the high-resolution 2-D ISH and projection images using the 3-D model.
• Link to associated gene metadata on the Allen Mouse Brain Atlas web application.

Installation
Windows
Systems requirement: minimum configuration
• Operating System: Microsoft Windows 7
• CPU: Intel Core Duo or AMD 1.8GHz
• System Memory: 1GB
• Graphics Card: Hardware 3D OpenGL accelerated AGP or PCI Express with 64MB RAM
• Screen: 1024x768, 32-bit true color
• Hard Disk: 200MB free space
Note: Brain Explorer is known to work with the following video chipsets: nVidia GeForce 9400/9600, nVidia Quadro FX 1800/3800/5600, AMD
Radeon 9600, AMD Radeon HD 3200/4550, Intel Q35/Q45 Express.
For the best performance, please check with your video card vendor for the latest available drivers before using Brain Explorer. The Windows
version of the Brain Explorer viewer is available here. Double-click the downloaded BrainExplorer2.msi file and follow the prompts.

Mac
Systems requirement: minimum configuration
• Operating System: OS X 10.6.8
• CPU: Intel 1.8GHz
• System Memory: 1GB
• Graphics Card: 3D-capable with 64MB RAM
• Screen: 1024x768, 32-bit millions of colors
• Hard Disk: 200MB free space
Note: Please install the latest system updates from Apple to ensure you have the latest video card drivers.
The Mac version of the Brain Explorer viewer is available here. Double-click the downloaded zip file to unpack Brain Explorer.

Installing Atlases
A one-time download containing anatomy files is needed following installation of the Brain Explorer application. The first time you open the Brain
Explorer software, you will be asked to choose to download files for the Allen Developing Mouse and Allen Human Brain atlases. Click on the
atlases you would like to use and then click the Install button.
To download missing atlases on the PC, go to the Help menu and select Download Atlases. On the Mac, the command is in the Brain Explorer 2
menu.

Getting Updates
The Brain Explorer application will inform you when updates to the Brain Explorer application itself or its atlases are available. New data may not
be available for viewing until you install the required updates.

Viewing Projection Data
To load projection data into the Brain Explorer viewer, go to the Allen Mouse Brain Connectivity Atlas and perform an efferent search. You can
also select a structure name from the list of injection sites. Your search brings back a list of experiments. Click on a row to select an experiment of
interest. A 3-D thumbnail of the projection data of that experiment will appear to the right. Click on the blue “View in 3D” file link to launch the
Brain Explorer application.

When the Brain Explorer 3-D Viewer opens, you will be taken to a screen that displays the Image Viewer, the Structure Ontology Viewer, and the
Gene/Projection List.

Image Viewer
The Image Viewer displays a 3-D representation of the neuronal projections in the selected experiment. Each sphere (when present) represents
the injection site re-sampled to a 100 micron grid resolution. Each line traces fluorescent signal through the brain and each cube represents
termination of signal. Larger polygons corresponds to a greater density of signal. Gene expression data can be displayed concurrently with the
projection data. Gene expression will also be represented by spheres as described in here.
You can select a sphere or cube by clicking on it. Volumes can be deselected by clicking on blank space. The original projection section of the
selected sphere/cube will be displayed blended with the projection segmentation in the lower left hand portion of the screen. The blending can be

adjusted by selecting Image Controls from the View menu and moving the Image Blending slider. Clicking on the arrow in the projection image will
open the corresponding image in a high resolution image viewer.

The information at the upper left corner of the main Brain Explorer window summarizes the fluorescent signal detected in the selected grid
location. This information includes the primary injection site, the annotated location of the selected point, average signal density and intensity
(over pixels) and the location. The Informatics Data Processing White Paper describes how the measurements were obtained.
To change the projection signal representation, click on the "Data" tab in the top left hand corner of your screen and select an option under “Raw”
colors.
A compass in the right-hand corner of the Image Viewer can be used to rotate the brain by clicking and dragging your cursor. You can zoom using
either the wheel on your mouse or using the Zoom scrollbar in the lower right hand corner of the Image Viewer.

Projection Thresholds
A way to control projection visibility is by setting thresholds on projection signal values. This method can restrict visible signals to different
combinations such as low intensity and low density or high intensity and low density.
The graph in the lower right hand corner shows a dot for each streamline endpoint, shown as a cube, in a projection experiment. The color of the
dot corresponds to the anatomic annotation in the same way the atlas colors display mode works. Each data point is plotted according to its
density on the x-axis and its intensity on the y-axis.
The thresholds can be changed by resizing the white box. Any edge or corner of the box can be clicked and dragged to re-size it. You can also
click and drag in the center of the box to move the box.

Structure Ontology Viewer
The Structure Ontology Viewer shows the entire collapsible ontology for the mouse brain as defined by the Allen Reference Atlas. Two columns to

the right of the ontology determine the type of data displayed in the Image Viewer. "A" represents annotation and when checked, will show a
visual representation of that structure in the Image Viewer. "D" represents signal density and when checked, will show signal in that structural
domain.
The default organization for the Structure Ontology is the Hierarchical View, but if you are unfamiliar with the ontology, you can click on the
Alphabetical View to see the structure list in alphabetical order.
The Bookmarks tab is a space where you can create and save favorite views of the brain. Several default views are already saved that will rotate
the brain back into common viewing frames.

Gene/Projection List
This section displays projection experiments you have selected as well as any gene
expression experiments you have downloaded in this session. Projection data is
indicated by a colored square, gene expression by a colored circle. Right clicking on the
gene name or injection site will bring up a menu where you can, 1) view the gene or
experiment detail page (Get Info), 2) be taken to a zoomed in image from this experiment
(View Images), 3) copy meta information to the clipboard, such as symbol, name, Entrez
ID, image-series ID (Copy Info), 4) activate a "Find Correlates" search finding
experiments with similar profiles (Find Similar) or 5) close the experiment and remove it
from the list and the 3-D view (Close).

Gene Search
To search for genes within the Brain Explorer application: go to the Search box located above the ontology panel and type in the gene symbol or
part of a gene name.
The list of results shows gene name, gene symbol along with a 3-D summary thumbnail of the expression for each experiment matching the
search. The expression thumbnail represents a maximum expression projection rendering: the denser the expression in a region the more "solid"
the appearance. Reference atlas colors are additionally layered on top.
To load an experiment for viewing click on the "Download" button under the gene name.

Toolbar
Button

Operation
Selects cursor rotation tool mode
Selects cursor pan tool mode
Selects cursor selection tool mode
Toggle Sagittal Atlas section viewing
Toggle Coronal Atlas section viewing
Toggle Horizontal Atlas section viewing
Centers the Viewer on the current pinpointed expression data point
Turns on the cutting planes
Toggles the Structure Ontology and Gene List View

Advanced Features
Atlas Tab:
You can show opaque three dimensional structures of the brain by "showing" or "hiding" structures from this menu. The "Transparent" function
allows you to see transparent views of the structures to view the anatomical relationships between them.
Selecting the sagittal, coronal or horizontal sections (or clicking on one of the section image buttons in the toolbar) will superimpose a single plane
of the Nissl images from each brain on your image space. These planes can be moved once the selection tool mode button in the toolbar is
selected. Selecting "Show Annotation on Section" from this menu will color the Nissl images according to the brain structure ontology.

Select “Show Full Resolution Image” to link to the high resolution annotation reference atlas images.

Data Tab:
The Data Tab menu allows to you to show all signal, hide all signal (for instance to then select a single structure) or toggle expression (for
instance, unselect your region of interest then toggle to see signal in only that region).
You can also show or remove threshold controls and choose the visual representation of your data from this menu. There are several options
under “Raw” colors:
• User defined: each experiment is rendered in user specified color. This mode is useful to distinguish between individual experiments when
multiple experiments are being displayed.
• Atlas: In this mode the signal is colored by the corresponding reference atlas structure color. This mode is useful for quickly seeing the
annotated regions where a fluorescent signal is detected.
• Signal Level: this mode display average signal intensity and is useful for identifying areas of very high signal.
To be taken to the experiment contact sheet page, select "Get Info". To see a high resolution view of the images in this experiment choose "View
Images". These functions are also available by right-clicking on the injection site/gene name in the Gene/Projection List.
Choose “Find Similar” to find similar experiments to the selected experiment. This uses the same NeuroBlast functionality as in the web
application.

Clipping Planes:
When this function is selected, either by toggling the cutting tools button in the toolbar or selecting "Clipping Planes" from the View drop down
menu, you can make coronal, sagittal or horizontal cuts in your view of the brain and related data. To cut in a particular plane, make sure the
cursor is in selection tool mode, and then click and drag on the plane you are interested in clipping.

Troubleshooting
Windows
Graphics
If you are using a desktop computer, you should obtain drivers from the video card manufacturer. First, identify the video card. Go the Start menu
and open the Control Panel. Open the Display control panel and go to the Settings tab. Click the Advanced button and go to the Adapter tab. Your
video card vendor and model name will be displayed at the top of the window under Adapter Type. Please go to the manufacturer's web site,
locate the driver download, and follow the instructions on the website or included with the downloaded file.
If you are using a laptop computer, you will need to go to your laptop manufacturer's web site to locate the latest video drivers.
You can also activate an alternate drawing mode in Brain Explorer. Go to the View menu and select Options. Check the Draw faster but at lower
quality button and uncheck the Synchronize drawing with the monitor's vertical refresh button. Set the Multisample setting to Off.
If you are using multiple video cards from different vendors, the 3-D display may not work correctly on all attached monitors.

Uninstalling
Use the Add/Remove Programs control panel or the uninstall link in the Brain Explorer folder in the Start menu. Additional data that are not
automatically uninstalled are located at the following locations:
Windows XP
Atlas data: C:\Documents and Settings\userid\Local Settings\Application Data\Allen Institute\Brain Explorer 2
User settings: C:\Documents and Settings\userid\Application Data\Allen Institute\Brain Explorer 2
Windows Vista and Windows 7
Atlas data: C:\Users\userid\AppData\Local\Allen Institute\Brain Explorer 2
User settings: C:\Users\userid\AppData\Roaming\Allen Institute\Brain Explorer 2

Proxy Settings
If you use a proxy server, the Brain Explorer application will use the proxy settings from the Internet Options control panel in the Windows Start
menu. Please refer to the Windows documentation for help on proxy settings.

Mac
Uninstalling
Drag the Brain Explorer 2 icon to the trash. The Brain Explorer application generates the following files, which can also be dragged to the trash.
~/Library/Application Support/Brain Explorer 2
~/Library/Preferences/org.alleninstitute.BrainExplorer2.plist

Performance
If the Brain Explorer application is not running smoothly, first try to free up as much memory as possible by quitting all other open applications.
You can also activate an alternate drawing mode. Go to the Brain Explorer 2 menu and select Preferences. Check the Draw faster but at lower
quality button and uncheck the Synchronize drawing with the monitor's vertical refresh button. Set Multisampling to Off.

