Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Section
Column
width800px
Wiki Markup

h1. Brain Explorer{reg-tm}{reg-tm} 2 3-D Viewer

The Brain Explorer 2 software is a desktop application for viewing human  neuroanatomy and the       Allen Human Brain Atlas microarray gene  expression data in 3-D in the framework of the Magnetic       Resonance Images  of the sampled brains.

h2. System Requirements


h4. Windows Minimum Configuration

Operating System: Microsoft Windows XP7
CPU: Intel Core Duo or AMD 1.8GHz
System Memory: 1GB
Graphics Card: Hardware 3D OpenGL accelerated AGP or PCI Express with 64MB RAM
Screen: 1024x768, 32-bit true color
Hard Disk: 200MB free space

Note: Brain Explorer is known to work with the following video  chipsets: nVidia GeForce 9400/9600, nVidia Quadro FX 1800/3800/5600, AMD  Radeon 9600, AMD Radeon HD 3200/4550, Intel Q35/Q45 Express
| (i) | *Important* \\
Please install the latest drivers for your video card for best compatibility and performance. |

h4. Mac Minimum Configuration

Operating System: OS X 10.56.8
CPU: Intel 1.8GHz
System Memory: 1GB
Graphics Card: 3D-capable with 64MB RAM
Screen: 1024x768, 32-bit millions of colors
Hard Disk: 200MB free space
| (i) | *Important* \\
Please install the latest system updates from Apple to ensure you have the latest video card drivers. |



h2. Installation


h4. Windows

For the best performance, please check with your video card vendor  for the latest available drivers before using Brain Explorer. The  Windows version of Brain Explorer is available [here|http://www.brain-map.org/BrainExplorer2/BrainExplorer2.msi]. Double-click the downloaded BrainExplorer2.msi file and follow the prompts.

h4. Mac

The Mac version of Brain Explorer is available [here|http://www.brain-map.org/BrainExplorer2/BrainExplorer2Mac.zip]. Double-click the downloaded zip file to unpack Brain Explorer.

h4. Installing Atlases

A one-time download containing anatomy files is needed following  installation of the Brain Explorer application. The first time you open  Brain Explorer, you will be asked to choose to download files for the  Mouse Brain, Developing Mouse Brain and Human Brain atlases. Click on  the atlases you would like to use and then click the Install button.

To download missing atlases on the PC, go to the Help menu and select  Download Atlases. On the Mac, the command is in the Brain Explorer 2  menu.

h4. Getting Updates

Brain Explorer will inform you when updates to the Brain Explorer  application itself or its atlases are available. New data may not be  available for viewing until you install the required updates.

h2. Viewing Gene Expression

To load gene expression data into Brain Explorer: go to the Allen Human Brain Atlas and perform a [gene search|humanbrain:Microarray Data]. You can click on a gene category in the tag cloud or type in a gene in the search box. Your search returns a heat map showing gene expression profiles over different structures in the brain. Click on a cell in the heat map - this selects a sample in your probe of interest. To see the gene expression for the probe you selected in 3D click on the Brain Explorer link to be taken to the Brain Explorer with the sample automatically highlighted.


!AHBA_BrainExplorerButton.png|border=1!


When the Brain Explorer 3-D Viewer opens, you will be taken to a screen that  displays the [#Image Viewer], the [#Structure Ontology Viewer], and the [#Gene List].



!BEnew.PNG|border=1!



h3. Image Viewer

The Image Viewer will automatically show the 3-D expression  representations of your gene of interest on every       sampled brain.  Cortical gene expression is overlaid on an inflated white       matter  surface for each donor brain, with spots under the cortical surface  representing gene       expression in the subcortical regions of the  brain. Under  each       representative brain is the heat map for the probe you  selected. Clicking on that heat map will       pinpoint the area in the  brain from which the sample was taken.

The gene expression colors correspond to the settings in the Atlas  with which you were viewing       the original heat map. To change the  gene expression representation, click on the "Gene" tab in       the top  left hand corner of your screen and choose either Z-score or raw colors.

A compass in the right hand corner of the image viewer depicted by a  stylized head can be used       to rotate the brains by clicking and  dragging your cursor. You can look at a single brain by       clicking  on the magnifying glass above that brain. The magnifying glass will appear as you hover over the donor ID for each brain. You can also remove a brain by clicking on the "x" next to the magnifying glass. !BE_3DView_CloseZoom.png! To restore all views, choose Show All Views from the View menu. Choosing a data point, either  by clicking on       the heat map below the brain or on a brain region  itself, will bring up the gene symbol, the       location of the sample  and the expression level and z-score in the top left hand corner of the  Image       Viewer.

You can zoom using either the wheel on your mouse or using the Zoom  scroll bar in the lower       right hand corner of the Image Viewer.

h3. Structure Ontology Viewer

The Structure Ontology Viewer shows the entire collapsible ontology  for the       human brain including the color coding used by our expert  annotation team to visualize structural       boundaries. Two columns to  the right of the ontology determine the type of data displayed in the        Image Viewer. "A" represents annotation and when checked, will show  a visual representation of       that structure in the Image Viewer.  "G" represents gene expression and when checked, will show       gene  expression in that structural domain.

The default organization for the Structure Ontology is the  Hierarchical View, but if you are       unfamiliar with the ontology,  you can click on the Alphabetical View to see the structure list in        alphabetical order.

The Bookmarks tab is a space where you can create and save favorite  views of the brain. Several       default views are already saved that  will rotate the brain back into common viewing frames.

h3. Gene List

This section displays the gene probes you have selected and  downloaded in this session. When       more than one gene probe has been  downloaded, clicking on one probe will show its gene       expression  profile in the image viewer. Right clicking on the gene probe name will  bring up a       menu where you can view the gene detail page (Get  Info), be taken to the Planar View of       the probe (View Images)  or copy the gene information for use in another application.

h3. Using the Toolbar

|| *Button* || *Operation* ||
| !brain_explorer_rotation.jpg|border=1,align=center! | Selects cursor rotation tool mode |
| !brain_explorer_pan.jpg|align=center,border=1! | Selects cursor pan tool mode |
| !brain_explorer_selection.jpg|align=center,border=1! | Selects cursor selection tool mode |
| !brain_explorer_sagittal.jpg|align=center,border=1! | Toggle Sagittal Atlas section viewing |
| !brain_explorer_coronal.jpg|align=center,border=1! | Toggle Coronal Atlas section viewing |
| !brain_explorer_horizontal.jpg|align=center,border=1! | Toggle Horizontal Atlas section viewing |
| !brain_explorer_center_viewer.jpg|align=center,border=1! | Centers the Viewer on the current pinpointed expression data point |
| !brain_explorer_cutting_planes.jpg|align=center,border=1! | Turns on the clipping planes |
| !brain_explorer_ontology_genes.jpg|align=center,border=1! | Toggles the Structure Ontology and Gene List View |

h3. Advanced Features

h4. Atlas Tab:

You can show opaque three dimensional structures of the brain by  "showing" or "hiding"       structures from this menu. The "Transparent"  function allows you to see transparent views of       the structures to  view the anatomical relationships between them.

Selecting the sagittal, coronal or horizontal sections (or clicking  on one of the        section image buttons in the toolbar) will  superimpose a single plane of the MRI images from each brain on your  image       space. These planes can be moved once the selection tool  mode button in the toolbar is selected. Selecting       "Show Annotation  on Section" from this menu will color the MRI images according to the  brain       structure ontology.

h4. Gene Tab:

When you have a gene selected, the Gene Tab menu allows to you to  show all expression, hide       all expression (for instance to then  select a single structure) or toggle expression (for instance,        unselect your region of interest then toggle to see expression in only  that region).

You can also show or remove threshold controls and choose the visual  representation of your       data (raw data vs. z-score) from this menu.

To be taken to the gene detail page, select "Get Info". To see the  Planar View, choose       "View Images". These functions are also  available by right-clicking on the gene name in the       Gene List.

h4. Clipping Planes:

When this function is selected, either by toggling the        cutting  tools button in the toolbar or selecting       "Clipping Planes" from  the View drop down menu, you can make coronal, sagittal or horizontal        cuts in your view of the brain and related data. To cut in a  particular plane, make sure the cursor       is in selection tool mode,  and then click and drag on the plane you are interested in clipping.

h2. Troubleshooting


h4. Windows


h5. Graphics

If you are using a desktop computer, you should obtain drivers from  the video card manufacturer. First, identify the video card. Go the  Start menu and open the Control Panel. Open the Display control panel  and go to the Settings tab. Click the Advanced button and go to the  Adapter tab. Your video card vendor and model name will be displayed at  the top of the window under Adapter Type. Please go to the  manufacturer's web site, locate the driver download, and follow the  instructions on the website or included with the downloaded file.

If you are using a laptop computer, you will need to go to your  laptop manufacturer's web site to locate the latest video drivers.

You can also activate an alternate drawing mode in Brain Explorer. Go  to the View menu and select Options. Check the Draw faster but at lower  quality button and uncheck the Synchronize drawing with the monitor's  vertical refresh button. Set the Multisample setting to Off.

If you are using multiple video cards from different vendors, the 3D display may not work correctly on all attached monitors.

h5. Uninstalling

Use the Add/Remove Programs control panel or the uninstall link in  the Brain Explorer folder in the Start menu. Additional data that are  not automatically uninstalled are located at the following locations:

Windows XP

Atlas data: C:\Documents and Settings\userid\Local Settings\Application Data\Allen Institute\Brain Explorer 2
User settings: C:\Documents and Settings\userid\Application Data\Allen Institute\Brain Explorer 2

Windows Vista and Windows 7

Atlas data: C:\Users\userid\AppData\Local\Allen Institute\Brain Explorer 2
User settings: C:\Users\userid\AppData\Roaming\Allen Institute\Brain Explorer 2

h5. Proxy Settings

If you use a proxy server, Brain Explorer will use the proxy settings  from the Internet Options control panel in the Windows Start menu.  Please refer to the Windows documentation for help on proxy settings.

h4. Mac


h5. Uninstalling

Drag the Brain Explorer 2 icon to the trash. Brain Explorer generates  the following files, which can also be dragged to the trash.
* \~/Library/Application Support/Brain Explorer 2
* \~/Library/Preferences/org.alleninstitute.BrainExplorer2.plist

h5. Performance

If Brain Explorer is not running smoothly, first try to free up as  much memory as possible by quitting all other open applications. You can  also activate an alternate drawing mode. Go to the Brain Explorer 2  menu and select Preferences. Check the Draw faster but at lower quality  button and uncheck the Synchronize drawing with the monitor's vertical  refresh button. Set Multisampling to Off.

h4. Contact Us

If after reading this help file you still have questions or suggestions, please [Contact Us|http://www.alleninstitute.org/contact_us/index.html].


Column