BRAIN EXPLORER

Brain Explorer® 3-D Viewer is an application for viewing brain anatomy and gene expression data in three dimensions in the framework of the Allen Reference Atlas.
Using Brain Explorer, you can:

• View a fully interactive version of the Allen Reference Atlas in 3-D.
• View gene expression data in 3-D at 200 µm 3 resolution.
• View expression data from multiple image series superimposed on each other in 3-D.
• Navigate the high-resolution 2-D ISH images using the 3-D model.
• Link to associated gene metadata on the Allen Mouse Brain Atlas web application.

Installation

Windows

Systems requirement: minimum configuration

• Operating System: Microsoft Windows 7
• CPU: Intel Core Duo or AMD 1.8GHz
• System Memory: 1GB
• Graphics Card: Hardware 3D OpenGL accelerated AGP or PCI Express with 64MB RAM
• Screen: 1024x768, 32-bit true color
• Hard Disk: 200MB free space

Note: Brain Explorer is known to work with the following video chipsets: nVidia GeForce 9400/9600, nVidia Quadro FX 1800/3800/5600, AMD Radeon 9600, AMD Radeon HD 3200/4550, Intel Q35/Q45 Express.

For the best performance, please check with your video card vendor for the latest available drivers before using Brain Explorer. The Windows version of the Brain Explorer viewer is available here. Double-click the downloaded BrainExplorer2.msi file and follow the prompts.

Mac

Systems requirement: minimum configuration

• Operating System: OS X 10.6.8
• CPU: Intel 1.8GHz
• System Memory: 1GB
• Graphics Card: 3D-capable with 64MB RAM
• Screen: 1024x768, 32-bit millions of colors
• Hard Disk: 200MB free space

Note: Please install the latest system updates from Apple to ensure you have the latest video card drivers.

The Mac version of the Brain Explorer viewer is available here. Double-click the downloaded zip file to unpack Brain Explorer.

Installing Atlases

A one-time download containing anatomy files is needed following installation of the Brain Explorer application. The first time you open the Brain Explorer software, you will be asked to choose to download files for the Allen Developing Mouse and Allen Human Brain atlases. Click on the atlases you would like to use and then click the Install button.

To download missing atlases on the PC, go to the Help menu and select Download Atlases. On the Mac, the command is in the Brain Explorer 2 menu.

Getting Updates

The Brain Explorer application will inform you when updates to the Brain Explorer application itself or its atlases are available. New data may not be available for viewing until you install the required updates.

Viewing Gene Expression

To load gene expression data into the Brain Explorer viewer: go the Allen Mouse Brain Atlas and perform a gene search. You can type in a gene in the search box or click on a structure name to retrieve differential enriched genes. Your search brings back a list of experiments. Click on a row to select an experiment of interest. A 3D thumbnail of the expression pattern of that experiment will appear to the right. Click on the blue “3D” file link to launch the Brain Explorer application.

When the Brain Explorer 3-D Viewer opens, you will be taken to a screen that displays the Image Viewer, the Structure Ontology Viewer, and the Gene List.

Image Viewer

The Image Viewer will automatically show the 3-D expression representation of your selected experiment. Each sphere represents expression re-sampled to a 200 micron grid resolution. Larger sphere corresponds to a greater density of expression.

You can select a sphere by clicking on it. Spheres can be deselected by clicking on blank space. The original ISH image of the selected sphere will be displayed blended with the expression heat mask in the lower left hand portion of the screen. The blending can be adjusted by selecting Image Controls from the View menu and moving the Image Blending slider. Double-clicking on the zoomed ISH image will open the corresponding ISH image in a high resolution image viewer.

The information at the upper left corner of the main Brain Explorer window summarizes the expression detected in the selected grid location. These numbers include the average expression density and intensity (over pixels). The Informatics Data Processing White Paper describes how the measurements were obtained.

To change the gene expression representation, click on the "Data" menu and select an option under “Raw” colors.

A compass in the right-hand corner of the Image Viewer can be used to rotate the brain by clicking and dragging your cursor. You can zoom using either the wheel on your mouse or using the Zoom scrollbar in the lower right hand corner of the Image Viewer.

Expression Thresholds

A way to control expression visibility is by setting thresholds on expression values. This method can restrict visible spheres to different combinations such as low intensity and low density or high intensity and low density.

The graph in the lower right hand corner shows a dot for each data point (sphere) in a gene expression file, and the color of the dot corresponds to the anatomic annotation in the same way the atlas colors display mode works. Each data point is plotted according to its density on the x axis and its intensity on the y axis.

The color scale on the left-hand side of the graph corresponds to the expression level heat map used to color the spheres. The numbers along each axis show the values at the yellow triangles.

The thresholds can be changed by resizing the white box. Any edge or corner of the box can be clicked and dragged to re-size it. You can also click and drag in the center of the box to move the box.

Structure Ontology Viewer

The Structure Ontology Viewer shows the entire collapsible ontology for the mouse brain as defined by the Allen Reference Atlas. Two columns to the right of the ontology determine the type of data displayed in the Image Viewer. "A" represents atlas structure and when checked, will show a visual representation of that structure in the Image Viewer. "D" represents gene expression and when checked, will show gene expression in that structural domain.

The default organization for the Structure Ontology is the Hierarchical View, but if you are unfamiliar with the ontology, you can click on the Alphabetical View to see the structure list in alphabetical order.

The Bookmarks tab is a space where you can create and save favorite views of the brain. Several default views are already saved that will rotate the brain back into common viewing frames.

Gene List

This section displays the gene probes you have selected and downloaded in this session. Right clicking on the gene probe name will bring up a menu where you can, 1) view the gene detail page (Get Info), 2) be taken to a zoomed-in image from this experiment (View Images), 3) copy meta information to the clipboard, such as symbol, name, Entrez ID, image-series ID (Copy Info), 4) activate a Correlation search, finding experiments with similar expression profiles (Find Similar) or 5) close the experiment and remove it from the list and the 3-D view (Close).

Gene Search

To search for genes within the Brain Explorer application: go to the Search box located above the ontology panel and type in the gene symbol or part of a gene name.

The list of results shows gene name, gene symbol along with a 3-D summary thumbnail of the expression for each experiment matching the search. The expression thumbnail represents a maximum expression projection rendering: the denser the expression in a region, the more "solid" the appearance. Reference atlas colors are additionally layered on top.

To load an experiment for viewing click on the "Download" button under the gene name.

Toolbar

Button

Operation

Selects cursor rotation tool mode

Selects cursor pan tool mode

Selects cursor selection tool mode

Toggle Sagittal Atlas section viewing

Toggle Coronal Atlas section viewing

Toggle Horizontal Atlas section viewing

Centers the Viewer on the current pinpointed expression data point

Turns on the cutting planes

Toggles the Structure Ontology and Gene List View

Advanced Features

Atlas Menu:

You can show opaque three dimensional structures of the brain by "showing" or "hiding" structures from this menu. The "Transparent" function allows you to see transparent views of the structures to view the anatomical relationships between them.

Selecting the sagittal, coronal or horizontal sections (or clicking on one of the section image buttons in the toolbar) will superimpose a single plane of the MRI images from each brain on your image space. These planes can be moved once the selection tool mode button in the toolbar is selected. Selecting "Show Annotation on Sections" from this menu will color the MRI images, if any are available, according to the brain structure ontology.

Select “Show Full Resolution Image” to link to the high resolution annotation reference atlas images.

To find genes enriched in particular structure: select a structure in the ontology tree then select “Find Genes” in the Atlas menu. This uses the same “Differential Search” functionality as the web application.

Data Menu:

When you have a gene selected, the Data menu allows to you to show all expression, hide all expression (for instance to then select a single structure) or toggle expression (for instance, unselect your region of interest then toggle to see expression in only that region).

You can also show or remove threshold controls and choose the visual representation of your data from this menu. There are several options under “Raw” colors:

• User defined: Each experiment is rendered in user specified color. This mode is useful to distinguish between individual experiments when multiple experiments are being displayed.
• Atlas: In this mode the sphere is colored by the corresponding reference atlas structure color. This mode is useful for quickly seeing the annotated regions where a gene is expressing.
• Expression Level: This mode displays average expression intensity and is useful for identifying areas of very high expression.
• Jet: Applies the common "jet" colormap to the data.

To be taken to the experiment detail page, select "Get Info". To explore the images in this experiment, choose "View Images". These functions are also available by right-clicking on the gene name in the Gene List.

Choose “Find Similar” to find similar genes to the selected experiment. This uses the same Correlation search functionality as in the web application.

Clipping Planes:

When this function is selected, either by toggling the cutting tools button in the toolbar or selecting "Clipping Planes" from the View drop down menu, you can make coronal, sagittal or horizontal cuts in your view of the brain and related data. To cut in a particular plane, make sure the cursor is in selection tool mode, and then click and drag on the plane you are interested in clipping.

Troubleshooting

Windows

Graphics

If you are using a desktop computer, you should obtain drivers from the video card manufacturer. First, identify the video card. Go the Start menu and open the Control Panel. Open the Display control panel and go to the Settings tab. Click the Advanced button and go to the Adapter tab. Your video card vendor and model name will be displayed at the top of the window under Adapter Type. Please go to the manufacturer's web site, locate the driver download, and follow the instructions on the website or included with the downloaded file.

If you are using a laptop computer, you will need to go to your laptop manufacturer's web site to locate the latest video drivers.

You can also activate an alternate drawing mode in Brain Explorer. Go to the View menu and select Options. Check the Draw faster but at lower quality button and uncheck the Synchronize drawing with the monitor's vertical refresh button. Set the Multisample setting to Off.

If you are using multiple video cards from different vendors, the 3-D display may not work correctly on all attached monitors.

Uninstalling

Use the Add/Remove Programs control panel or the uninstall link in the Brain Explorer folder in the Start menu. Additional data that are not automatically uninstalled are located at the following locations:

Windows XP

Atlas data: C:\Documents and Settings\userid\Local Settings\Application Data\Allen Institute\Brain Explorer 2
User settings: C:\Documents and Settings\userid\Application Data\Allen Institute\Brain Explorer 2

Windows Vista and Windows 7

Atlas data: C:\Users\userid\AppData\Local\Allen Institute\Brain Explorer 2
User settings: C:\Users\userid\AppData\Roaming\Allen Institute\Brain Explorer 2

Proxy Settings

If you use a proxy server, the Brain Explorer application will use the proxy settings from the Internet Options control panel in the Windows Start menu. Please refer to the Windows documentation for help on proxy settings.

Mac

Uninstalling

Drag the Brain Explorer 2 icon to the trash. The Brain Explorer application generates the following files, which can also be dragged to the trash.

Performance

If the Brain Explorer application is not running smoothly, first try to free up as much memory as possible by quitting all other open applications. You can also activate an alternate drawing mode. Go to the Brain Explorer 2 menu and select Preferences. Check the Draw faster but at lower quality button and uncheck the Synchronize drawing with the monitor's vertical refresh button. Set Multisampling to Off.