Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Section
Column
width800px
Wiki Markup



h1. Brain Explorer



Brain Explorer® 3-D Viewer is an application for viewing brain anatomy and gene expression data in 3D. It is integrated with three Allen Brain Atlas online resources: the Allen Human Brain Atlas, the Allen Mouse Brain Atlas and the Allen Developing Mouse Brain Atlas.


Using Brain Explorer, you can:


View a fully interactive version of the Allen Mouse Brain Atlas in 3D.


View overlapping expression data from different genes.


Investigate probes or samples of interest in more detail with direct links back to the Allen Mouse Brain Atlas.


Navigate the high-resolution 2D ISH images.

Installation

Windows

For the best performance, please check with your video card vendor for the latest available drivers before using Brain Explorer. The Windows version of Brain Explorer is available here. Double-click the downloaded BrainExplorer2.msi file and follow the prompts.

Mac

The Mac version of Brain Explorer is available here. Double-click the downloaded zip file to unpack Brain Explorer.

Installing Atlases

A one-time download containing anatomy files is needed following installation of the Brain Explorer application. The first time you open Brain Explorer, you will be asked to choose to download files for the Developing Mouse and Human Brain atlases. Click on the atlases you would like to use and then click the Install button.

To download missing atlases on the PC, go to the Help menu and select Download Atlases. On the Mac, the command is in the Brain Explorer 2 menu.

Getting Updates

Brain Explorer will inform you when updates to the Brain Explorer application itself or its atlases are available. New data may not be available for viewing until you install the required updates.

Quick Start: Viewing Gene Expression

To load gene expression data into Brain Explorer: go to the Allen Mouse Brain Atlas and perform a gene search. Your search returns a list of experiments with gene expression profiles that match your search criteria. To the right of this list is a box that shows a 3-D image of your gene expression and a link to the Brain Explorer application.

See also on the Brain Explorer section on the Allen Human Brain Atlas help page.

3D Controls and Viewing Brain Anatomy

The main Brain Explorer window is shown below and is divided into 3 main areas. The main view shows brain anatomy and gene expression in 3D. The structural ontology panel is the dominant feature on the right hand side of the window and shows the color-coded hierarchy. The ontology can be switched between hierarchical and alphabetical mode by clicking on the corresponding buttons below the list. The Bookmark button displays saved default and custom views. At the bottom right hand side of the window is the list of genes shown in the 3D view (empty in this screenshot).

Image Removed

Viewing 3D Structures

Each 3D view is based upon the Nissl stained underlying 3D volume.

To view brain structures in a 3D view:

  • Go to the Atlas menu and select Show Outer Structures. Look at the checkboxes in the ontology list. You will see there are checks in the "A" column (short for Atlas) for the structures that are now visible. Structures can be turned on and off as desired using these checkboxes. The Transparent option from the Atlas menu is useful when viewing expression data.
    You can rotate and pan the view to see structures which are hidden behind other structures in the view. Click and drag the ball in the upper right corner of the window to rotate the brain. If you get lost, go to the View menu and select Reset to return to a default view of the brain.
    If the cursor is moving when you release the mouse button, the view will continue rotating until you click again. The rotation speed is based on the speed of the cursor. You can turn this automatic animation feature off from the Options item in the View menu.
    To center the rotation around a particular structure:
  • Choose the Panning tool in the toolbar
  • Click near the bottom of the 3D view and drag towards the top of the window until the structure is centered.
  • Move the zoom slider (located at the bottom of the window) to the right to enlarge the 3D objects in view. If you have a scroll wheel on your mouse, rotating the wheel will also zoom the view.
  • Keep zooming and panning until the structure approximately centered.
  • Move the cursor to the ball in the upper right corner, and click and drag the mouse to rotate about the structure.

Selecting a structure in the ontology will highlight the corresponding 3D structure in bright green. Selecting the structure in the 3D view will also highlight the corresponding structure in the ontology.

  • Choose the Selection tool in the toolbar.
  • Click on various structures in the 3D view and note how the ontology list selection changes.
  • Click on blank space to deselect the selected structure.

Shortcuts

At this point, you have learned how to rotate, pan, and select. Since moving between these actions quickly is very common, the tools have been mapped to the buttons on a multi-button mouse. When the Rotation tool is selected, the view tools correspond to the mouse buttons as shown to the right. The left mouse button will rotate the view, the middle button (or clickable scroll wheel) will pan the view, and the right mouse button will select objects in the view. When the Selection tool is clicked, the function of the left and right mouse buttons is swapped.

Sometimes, you may want fine control over rotation and panning. The view can be nudged a small amount by using the following shortcut keys.

  • The arrow keys rotate the view
  • Ctrl + arrow keys pan the view in Windows
  • Command + arrow keys pan the view in Mac OS X

Viewing 2D Sections

In addition to the 3D polygonal structures, you can also turn on planar views of the underlying 3D volume and associated annotations.

  • From the View menu, choose Reset.
  • Click on the Sagittal Sections icon in the toolbar. Sometimes the volume can be quite large, so your computer may pause while it is loading. When loading is complete, click the coronal and horizontal section toolbar icons.In the screen shot you are looking at three planar views of the volume with annotations superimposed on top of it.
    You can locate the planar views in any section of the brain you choose:
  • Rotate the view so that the axes are diagonal.
  • Click on one of the planar views.
  • With the left mouse button held down, drag the cursor to move that planar view along its axis. Note that the images changes to reflect the section at the current location.
  • Click and release the mouse on any annotated part of a section to identify the structure underneath the cursor. Note that you must not drag the mouse while the mouse button is down or you will end up dragging the section instead of selecting a structure.

Shortcuts

The following keyboard controls can be used for fine control over section selection.

F1

Show/hide sagittal section

F2

Show/hide coronal section

F3

Show/hide horizontal section

Clipping Planes

Although you have fine control over the visibility of structures using the controls in the ontology list, sometimes you may want finer control over parts of structures we have not subdivided. Or perhaps you would like to look inside one or more structures. Using the clipping planes tool, you can specify a volume of interest to view.

  • From the View menu, select Reset. Also, hide the planar views if desired.
  • From the Atlas menu, select Show Outer Structures.
  • From the toolbar, select the Clipping Planes icon.As with the planar views, it's easiest to control the clipping planes if the view is rotated off axis. Place the cursor on each face of the cube outlined in green and drag the faces to cut away parts of the brain.
  • You may also deselect View Clipping planes or press Ctrl+L to toggle off the clipping plane controls and display only the cut brain view.Note: The performance of this feature is highly dependent on your video hardware. It may not work well on certain chipsets. If performance is slow, reset the view to disable all clipping. Then try to move as few planes as possible from their starting positions. Also, try to remove as many objects as possible from view. Show only essential structures and genes of interest.

Bookmarks

Certain aspects of the 3-D view can be saved as bookmarks so that you can go back to the same view later.

Basics

First, reset the view and switch to the bookmarks view.

  • From the View menu, choose Reset. Close each item in your gene list. From the Atlas menu, make sure Transparent is off and choose Hide All Structures.
  • Click the Bookmarks tab in the main window.

Some standard anatomic views are provided in the initial set of default bookmarks. Bookmarks can be organized in groups.

  • From the Atlas menu, choose Show Outer Structures.
  • Click on Coronal - Caudal to Rostral bookmark under Views. The view should rotate to the caudal to rostral orientation.
  • While holding down the Control (Option on Mac) key, click on Coronal - Rostral to Caudal. The view switches right away instead of animating when the Control (Option on Mac) key is held down.
  • The animation speed can be adjusted in the Options command in the View menu (Preferences in the Brain Explorer 2 menu on Mac). You can also highlight bookmarks using the keyboard and navigate to them by pressing the Enter key.
    Now let's define a new bookmark.
  • Rotate the view to about 45 degrees off the sagittal left to right view and zoom in a bit.
  • Deselect all bookmarks by clicking on an empty area in the bookmarks list. Make sure no items are highlighted in the bookmarks list.
  • From the Bookmarks menu, choose New Group. Type in a name and press the Enter key.
  • Choose New Bookmark from the Bookmarks menu.The first 2 checkboxes correspond to the A and G columns in the Alphabetical and Hierarchical atlas ontology views. If you bookmark Atlas Structures, then the state of all checkboxes in the A column are saved. For instance, if you have the checkbox in the A column next to Cerebral cortex (CTX) checked and create a bookmark with Atlas Structure enabled, then returning to this bookmark will show the cortex and hide all other structures.
    The View Angle option corresponds to the rotation of the 3D view. The View Zoom corresponds to the position of the Zoom slider beneath the 3D view.
    Atlas Sections records the visibility and position of the coronal, horizontal, and sagittal sections. Clipping Planes records the position of the clipping planes.
  • Type in a name and click Save. You can edit the bookmark name or delete the bookmark by right-clicking on it and selecting the appropriate menu item.

Snapback

When you go to a bookmark, your view is automatically saved as a temporary bookmark. You can go back to the previous view by choosing Go Back from the Bookmarks menu. You can set the temporary bookmark manually by choosing Mark for Snapback from the Bookmarks menu.

  • Rotate the view and adjust the zoom.
  • Click on the bookmark you created above.
  • Choose Go Back from the Bookmarks menu.

Keep in mind the snapback bookmark can restore your previous view if you accidentally click on a bookmark.

Gene Expression Viewing and Controls

View Controls

The figure to the right shows the gene Rspo1 at E13.5. The spheres represent expression resampled to a 100μm grid resolution. Larger spheres correspond to a greater density of expression (in terms of pixels).

  • Click on a sphere. Spheres can be deselected by clicking on blank space.The original ISH image for the selected grid is displayed blended with the expression heat mask shown in the lower left hand portion of the screen. The blending can be adjusted by selecting Image Controls from the View menu and moving the Image Blending slider. The zoomed ISH image is shown with tick marks at 100μm intervals. Double-clicking on the zoomed ISH image will open the corresponding ISH image in a high resolution image viewer.
    The information at the upper left corner of the main Brain Explorer window summarizes the expression detected in the selected grid location. These numbers include the average expression density and intensity (over pixels). The Informatics White Paper describes how the measurements were obtained. In the Atlas menu, you can select Show Enclosing Structure to quickly see the anatomy surrounding the selection.
    By default, each gene loaded is represented in a different color. This mode is useful for viewing multiple genes at the same time for comparison. Other modes can be accessed from the Colors submenu in the Gene menu. Atlas color mode correspond to search result thumbnail display. This mode is useful for quickly seeing the annotated regions where a gene is expressing. Expression Level mode display average expression intensity corresponding to the scale shown to the right. Expression level mode is good for identifying areas of very high expression or looking at a densely expressing gene that is not expressing at a uniform level everywhere in the brain.
    Note: Only one half of the brain is annotated. For sagittal data sets, most of the grid locations should have an annotation. For coronal data sets, half of the brain will not be annotated. There is a special "No Annotation" label at the bottom of the ontology list. You can toggle the "G" column checkbox for this label to show or hide grid locations that are not annotated. | |

Expression Thresholds

Another way to control expression visibility is by setting thresholds on expression values. This method can restrict visible spheres to different combinations such as low intensity and low density or high intensity and low density.

The graph in the lower right hand corner shows a dot for each data point (sphere) in a gene expression file, and the color of the dot corresponds to the anatomic annotation in the same way the atlas colors display mode works. Each data point is plotted according to its density on the x axis and its intensity on the y axis.

The color scale on the left hand side of the graph corresponds to the expression level heat map used to color the spheres. The numbers along each axis show the values at the yellow triangles.

The thresholds can be changed by resizing the white box. Any edge or corner of the box can be clicked and dragged to resize it. You can also click and drag in the center of the box to move the box.

In the figure above, the thresholds were adjusted to show grid location with high intensity values.

Advanced Controls

Preferences

Customization options are available from the Options command in the View menu. These options are:

Automatic update checks

If enabled, informs you when new versions of Brain Explorer and its associated atlases are released.

Automatic rotation

Enables or disables automatic rotation animation when releasing the mouse button while dragging.

Bookmark animation speed

Controls the length of time spent on animating to bookmarked views. Move the slider all the way to the right (Instant) to disable the animation.

Draw faster but at lower quality

Brain Explorer will use simpler 3D representations with this option on. This option can significantly increase the frame rate for some video cards.

Synchronize drawing with monitor vertical refresh

Turning this option off can increase the frame rate at the expense of some graphical "tearing". An example of tearing would be seeing parts of the screen drawn with the brain at different rotation angles. Turning this option on can minimize tearing at the expense of frame rate.

Multisampling

This option reduces polygon "jaggies" but at the expense of frame rate. Turn this option on only if you are comfortable with your present frame rate.

Shortcuts Summary

F1

Show/hide sagittal section

F2

Show/hide coronal section

F3

Show/hide horizontal section

F4

Show full resolution atlas image

Arrow keys

Rotate view

Ctrl (or command on Mac) + arrow keys

Pan view

Ctrl (or command on Mac) + select object

Center the view on the object

Troubleshooting

Windows

Graphics

If you are using a desktop computer, you should obtain drivers from the video card manufacturer. First, identify the video card. Go the Start menu and open the Control Panel. Open the Display control panel and go to the Settings tab. Click the Advanced button and go to the Adapter tab. Your video card vendor and model name will be displayed at the top of the window under Adapter Type. Please go to the manufacturer's web site, locate the driver download, and follow the instructions on the website or included with the downloaded file.

If you are using a laptop computer, you will need to go to your laptop manufacturer's web site to locate the latest video drivers.

You can also activate an alternate drawing mode in Brain Explorer. Go to the View menu and select Options. Check the Draw faster but at lower quality button and uncheck the Synchronize drawing with the monitor's vertical refresh button. Set the Multisample setting to Off.

If you are using multiple video cards from different vendors, the 3D display may not work correctly on all attached monitors.

Uninstalling

Use the Add/Remove Programs control panel or the uninstall link in the Brain Explorer folder in the Start menu. Additional data that are not automatically uninstalled are located at the following locations:

Windows XP

Atlas data: C:\Documents and Settings\userid\Local Settings\Application Data\Allen Institute\Brain Explorer 2
User settings: C:\Documents and Settings\userid\Application Data\Allen Institute\Brain Explorer 2

Windows Vista and Windows 7

Atlas data:



h3. Installation


h4. Windows

For the best performance, please check with your video card vendor  for the latest available drivers before using Brain Explorer. The  Windows version of Brain Explorer is available [here|http://www.brain-map.org/BrainExplorer2/BrainExplorer2.msi]. Double-click the downloaded BrainExplorer2.msi file and follow the prompts.

h4. Mac

The Mac version of Brain Explorer is available [here|http://www.brain-map.org/BrainExplorer2/BrainExplorer2Mac.zip]. Double-click the downloaded zip file to unpack Brain Explorer.

h4. Installing Atlases

A one-time download containing anatomy files is needed following  installation of the Brain Explorer application. The first time you open  Brain Explorer, you will be asked to choose to download files for the  Developing Mouse and Human Brain atlases. Click on the atlases you would  like to use and then click the Install button.

To download missing atlases on the PC, go to the Help menu and select  Download Atlases. On the Mac, the command is in the Brain Explorer 2  menu.

h4. Getting Updates

Brain Explorer will inform you when updates to the Brain Explorer  application itself or its atlases are available. New data may not be  available for viewing until you install the required updates.

h3. Brain Explorer{reg-tm}{reg-tm} 2 3-D Viewer

The Brain Explorer 2 software is a desktop application for viewing human  neuroanatomy and the       Allen Human Brain Atlas microarray gene  expression data in 3-D in the framework of the Magnetic       Resonance Images  of the sampled brains.

Once you have chosen a gene of interest (by clicking on the heat  map), you can explore a three-dimensional representation of its  gene expression by clicking on the "Brain Explorer" link over       the  heat map. When the Brain Explorer 3-D Viewer opens, you will be taken to a screen that  displays the [#Image Viewer], the [#Structure Ontology Viewer], and the  [#Gene List].


!brain_explorer.jpg|border=1!


h4. Image Viewer

The Image Viewer will automatically show the 3-D expression  representations of your gene of interest on every       sampled brain.  Cortical gene expression is overlaid on an inflated white       matter  surface for each donor brain, with spots under the white surface  representing gene       expression in the subcortical regions of the  brain. A striped expression pattern on the cortical       surface is a  result of having sampled from every other slab of cortical tissue. Under  each       representative brain is the heat map for the probe you  selected. Clicking on that heat map will       pinpoint the area in the  brain from which the sample was taken.

The gene expression colors correspond to the settings in the Atlas  with which you were viewing       the original heat map. To change the  gene expression representation, click on the "Gene" tab in       the top  left hand corner of your screen and choose either Z-score or raw colors (as per App).

A compass in the right hand corner of the image viewer depicted by a  stylized head can be used       to rotate the brains by clicking and  dragging your cursor. You can look at a single brain by       clicking  on the magnifying glass above that brain. Choosing a data point, either  by clicking on       the heat map below the brain or on a brain region  itself, will bring up the gene symbol, the       location of the sample  and the expression level and z-score in the left hand corner of the  Image       Viewer.

You can zoom using either the wheel on your mouse or using the Zoom  scrollbar in the lower       right hand corner of the Image Viewer.

h4. Structure Ontology Viewer

The Structure Ontology Viewer shows the entire collapsible ontology  for the       human brain including the color coding used by our expert  annotation team to visualize structural       boundaries. Two columns to  the right of the ontology determine the type of data displayed in the        Image Viewer. "A" represents annotation and when checked, will show  a visual representation of       that structure in the Image Viewer.  "G" represents gene expression and when checked, will show       gene  expression in that structural domain.

The default organization for the Structure Ontology is the  Hierarchical View, but if you are       unfamiliar with the ontology,  you can click on the Alphabetical View to see the structure list in        alphabetical order.

The Bookmarks tab is a space where you can create and save favorite  views of the brain. Several       default views are already saved that  will rotate the brain back into common viewing frames.

h4. Gene List

This section displays the gene probes you have selected and  downloaded in this session. When       more than one gene probe has been  downloaded, clicking on one probe will show its gene       expression  profile in the image viewer. Right clicking on the gene probe name will  bring up a       menu where you can view the gene detail page (Get  Info), be taken to the Planar View of       the probe (View Images)  or copy the gene information for use in another application.

h4. Toolbar

||*Button*||*Operation*||
|!brain_explorer_rotation.jpg|border=1,align=center!| Selects cursor rotation tool mode |
|!brain_explorer_pan.jpg|align=center,border=1!| Selects cursor pan tool mode |
|!brain_explorer_selection.jpg|align=center,border=1!| Selects cursor selection tool mode |
|!brain_explorer_sagittal.jpg|align=center,border=1!| Toggle Sagittal Atlas section viewing |
|!brain_explorer_coronal.jpg|align=center,border=1!| Toggle Coronal Atlas section viewing |
|!brain_explorer_horizontal.jpg|align=center,border=1!| Toggle Horizontal Atlas section viewing |
|!brain_explorer_center_viewer.jpg|align=center,border=1!| Centers the Viewer on the current pinpointed expression data point |
|!brain_explorer_cutting_planes.jpg|align=center,border=1!| Turns on the cutting planes |
|!brain_explorer_ontology_genes.jpg|align=center,border=1!| Toggles the Structure Ontology and Gene List View |

h4. Advanced Features

*Atlas Tab:*

You can show opaque three dimensional structures of the brain by  "showing" or "hiding"       structures from this menu. The "Transparent"  function allows you to see transparent views of       the structures to  view the anatomical relationships between them.

Selecting the sagittal, coronal or horizontal sections (or clicking  on one of the        section image buttons in the toolbar) will  superimpose a single plane of the MRI images from each brain on your  image       space. These planes can be moved once the selection tool  mode button in the toolbar is selected. Selecting       "Show Annotation  on Section" from this menu will color the MRI images according to the  brain       structure ontology.

*Gene Tab:*

When you have a gene selected, the Gene Tab menu allows to you to  show all expression, hide       all expression (for instance to then  select a single structure) or toggle expression (for instance,        unselect your region of interest then toggle to see expression in only  that region).

You can also show or remove threshold controls and choose the visual  representation of your       data (raw data vs. z-score) from this menu.

To be taken to the gene detail page, select "Get Info". To see the  Planar View, choose       "View Images". These functions are also  available by right-clicking on the gene name in the       Gene List.

*Clipping Planes:*

When this function is selected, either by toggling the        cutting  tools button in the toolbar or selecting       "Clipping Planes" from  the View drop down menu, you can make coronal, sagittal or horizontal        cuts in your view of the brain and related data. To cut in a  particular plane, make sure the cursor       is in selection tool mode,  and then click and drag on the plane you are interested in clipping.


h1. Troubleshooting


h2. Windows


h3. Graphics

If you are using a desktop computer, you should obtain drivers from  the video card manufacturer. First, identify the video card. Go the  Start menu and open the Control Panel. Open the Display control panel  and go to the Settings tab. Click the Advanced button and go to the  Adapter tab. Your video card vendor and model name will be displayed at  the top of the window under Adapter Type. Please go to the  manufacturer's web site, locate the driver download, and follow the  instructions on the website or included with the downloaded file.

If you are using a laptop computer, you will need to go to your  laptop manufacturer's web site to locate the latest video drivers.

You can also activate an alternate drawing mode in Brain Explorer. Go  to the View menu and select Options. Check the Draw faster but at lower  quality button and uncheck the Synchronize drawing with the monitor's  vertical refresh button. Set the Multisample setting to Off.

If you are using multiple video cards from different vendors, the 3D display may not work correctly on all attached monitors.

h3. Uninstalling

Use the Add/Remove Programs control panel or the uninstall link in  the Brain Explorer folder in the Start menu. Additional data that are  not automatically uninstalled are located at the following locations:

Windows XP

Atlas data: C:\Documents and Settings\userid\Local Settings\Application Data\Allen Institute\Brain Explorer 2
User settings: C:\Documents and Settings\userid\Application Data\Allen Institute\Brain Explorer 2

Windows Vista and Windows 7

Atlas data: C:\Users\userid\AppData\Local\Allen Institute\Brain Explorer 2


User settings: C:\Users\userid\AppData\Roaming\Allen Institute\Brain Explorer 2


h3. Proxy Settings


If you use a proxy server, Brain Explorer will use the proxy settings  from the Internet Options control panel in the Windows Start menu.  Please refer to the Windows documentation for help on proxy settings.

h2.

Mac

Uninstalling

Drag the Brain Explorer 2 icon to the trash. Brain Explorer generates the following files, which can also be dragged to the trash.

 Mac


h3. Uninstalling

Drag the Brain Explorer 2 icon to the trash. Brain Explorer generates  the following files, which can also be dragged to the trash.
* \~/Library/Application Support/Brain
Explorer 2
 Explorer 2
* \~/Library/Preferences/org.alleninstitute.BrainExplorer2.plist

Performance

If Brain Explorer is not running smoothly, first try to free up as much memory as possible by quitting all other open applications. You can also activate an alternate drawing mode. Go to the Brain Explorer 2 menu and select Preferences. Check the Draw faster but at lower quality button and uncheck the Synchronize drawing with the monitor's vertical refresh button. Set Multisampling to Off.

Contact Us

If after working through this tutorial you still have questions or suggestions, please Contact Us.


h3. Performance

If Brain Explorer is not running smoothly, first try to free up as  much memory as possible by quitting all other open applications. You can  also activate an alternate drawing mode. Go to the Brain Explorer 2  menu and select Preferences. Check the Draw faster but at lower quality  button and uncheck the Synchronize drawing with the monitor's vertical  refresh button. Set Multisampling to Off.

h1. Contact Us

If after working through this tutorial you still have questions or suggestions, please [Contact Us|http://www.alleninstitute.org/contact_us/index.html].
Column